Friday, April 26, 2013

Disqus Error in Blogger

If you are getting the below error in IE9 after configuring the Disqus in your blogger site

This page is forcing your browser to use legacy mode, which is not compatible with Disqus.Please see our troubleshooting guide to get more information about this error.

Troubleshoot the error

This error occurring is due to IE7 emulation. Some websites force Internet Explorer to load emulating an older version of Internet Explorer. You can check by opening the development tools (Press F12) and checking the Document Mode.

If it says Internet Explorer 7 Standards, you can switch this to Internet Explorer 8/9 Standards to load Disqus properly. If you are a user of this webpage you can follow this.

If you are the owner of this blog you can correct this issue.
The most common reason the page would load in IE7 standards is because of the EmulateIE7 meta tags. Look in your page source and find an HTML tag similar to this:

Click on Template->Edit HTML-> Edit Template-> Ctrl+F and Search for 'EmulateIE7' in the editor window. Following line will appear.

<meta content='IE=EmulateIE7' http-equiv='X-UA-Compatible'/>

You can either remove this or change it to use the latest version of IE available as follows:

<meta content='IE=9; IE=8; IE=7; IE=EDGE; chrome=1'  http-equiv='X-UA-Compatible'/>

Then open the development tool again (press F12) in your site and you can see the document mode changed in to IE9 standards. Now the Disqus will load properly.

Now see the Disqus will appear as follows.

Try it out..